Se connecter à un serveur NAS Synology DS108J

Accueil FORUM Installation Se connecter à un serveur NAS Synology DS108J

Ce sujet a 78 réponses, 4 participants et a été mis à jour par  lecardiologue, il y a 7 ans et 6 mois.

15 sujets de 61 à 75 (sur un total de 79)
  • Auteur
    Messages
  • #775

    lecardiologue
    Participant

    Petit mesage ce matin pour dire que j’ai installé sur un PC équipé d’UBUNTU toutes les bases vierges de Medintux. Fin du processus OK
    Je l’ai fait en localhost puis sur mon SYNO, pas de problème.
    Puis restauration de mon dump DrTUXTEST fait sous environnement initial Windows —> échec cuisant mais c’est logique si on se rappèle de la réponse de Roland.

    Roland je suis ok pour te transmettre mon dump DrTUX pour réorthographier correctement les tables de cette base.
    Comment procède-t-on ?

    Merci de me preciser la marche a suivre…et merci beaucoup.

    #781

    lecardiologue
    Participant

    Ceci est probablement mon dernier post sur le sujet.

    Je suis dans une impasse…

    Je crois avoir épuisé toutes les solutions concernant l’installation des bases sur le serveur NAS Synology.

    Ma dernière tentative a été d’installer par setbases toutes les bases en localhost (configuration monoposte)sous système 7 de Windows et sur le NAS.

    En monoposte tout s’est bien passé, les bases sont initialisées, la récupération des données s’est faite sans problème.

    Sur le NAS je constate que les bases sont installées, initialisées, la connexion au serveur MYSQL est fonctionnelle. En revanche, des changements ont été opérés : le nombre de tables par bases est différent par rapport à ma configuration en monoposte et elles sont mal orthographiées (cf la réponse de Roland Sevin à ce sujet).

    J’ai donc réorthographié toutes les tables (passage de majuscule en minuscule) et supprimé les tables « en trop » apparues dans le NAS pour certaines bases (curieux, non ?). Au passage j’ai aussi restauré avec le bouton « importer un fichier sql » de setbases ma base DrTuxTest.

    En fin de processus, j’ai tenté la reconnection au serveur sans succès cette fois alors que la construction des bases me semblait opérée.

    Voila je sais plus quoi faire…si en fait j’envisage d’investir sur un PC qui me servira de serveur dédié sur lequel je pense qu’il n’y aura pas de souci de ce type (enfin j’espère !)

    #785

    Victor
    Admin bbPress

    Il y a quelque chose que je ne saisi pas : tu dis « Sur le NAS je constate que les bases sont installées, initialisées, la connexion au serveur MYSQL est fonctionnelle.  » si la connexion au serveur MySQL est fonctionnelle c’est que ça fonctionne, non ?

    tu mentionnes également avoir importé « au passage » un fichier SQL (DrTuxTest). Essaie de dissocier tes opérations entre chaque lancement de MedinTux pour être certain de cibler d’ou vient le problème de connexion

    #791

    lecardiologue
    Participant

    « Il y a quelque chose que je ne saisi pas : tu dis « Sur le NAS je constate que les bases sont installées, initialisées, la connexion au serveur MYSQL est fonctionnelle »

    oui en effet, c’est le résultat de l’installation des bases « vierges » par setbases. Autremendit je n’y ai pas fait de stockage de fichier patient.
    Dans cette situation l’ecran de setbases indique : Connexion SQL établie

    Bases de données trouvées : 7
    . ‘DrTuxTest’
    . ‘MedicaTuxTest’
    . ‘BaseGetTest’
    . ‘CIM10Test’
    . ‘CCAMTest’
    . ‘QLaboFTP’
    . ‘Comptabilite’

    (==> Succès lors du test de l’accès à la base : test)
    ============ Erreur : GetMAJVersion()==============
    Erreur Get Version() initialisaton de la base non possible, installation des bases non correcte
    Echec de la connexion à Driver : QMYSQL3 base : DrTuxTest avec root@192.168.0.14:3306

    Je n’ai pas le bouton a gauche qui permettrait de lancer Medintux.

    je suis désolé mais je ne peux pas faire de capture d’écran.

    #792

    Victor
    Admin bbPress

    ok. Je pense que cette erreur est liée à la version de MySQL installée sur le syno comme nous en avons discuté précédemment.

    Peut-être qu’un des développeurs peut nous dire si c’est totalement impossible de faire fonctionner medintux avec une version de MySQL < 5.5.1 (je suppose que certaines fonctions utilisées sont propres à la nouvelle version de MySQL d'où la nécessité d'utilise la nouvelle version). Dans ce cas, tant que le SYNO ne sera pas équipé de MySQL 5.5.1, ça ne fonctionnera pas. Snon une solution moins radicale que de tout mettre sur pc serait freenas.


    lecardiologue
    Participant

    Merci pour ta réponse Victor !

    je viens de faire une manip sur mon SYNO dont le resultat me surprend :

    J’ai desintallé proprement phpMyAdmin avec l’interface d’administration du NAS, j’ai téléchargé la toute derniere version de phpmyadmin sur le site de l’editeur (il fourni un client mysql 5.5).
    J’ai fait un copier-coller de tout le repertoire phpmyadmin à la place où était l’ancienne version.

    J’ai relancé setbases après et ai obtenu un econnexion SQL avec réaparition du bouton « demarrer Medintux ».
    En le faisant Medintux s’est lancé sans problème.
    Je vais essayer de restaurer ma base DrTuxTest où j’ai mes cent patients.

    pourquoi pas ?

    #796

    dajon
    Participant

    Extra. Si tu as pu faire une MAJ sql ça devrait marcher maintenant. Mais comment as tu fait car d’après les infos éditeur syno la version sql est plus ancienne, à moins que cela ne soit possible qu’une fois la nas acheté de faire la mise à jour ensuite depuis le nas ?? ??

    #797

    lecardiologue
    Participant

    « Si tu as pu faire une MAJ sql ça devrait marcher maintenant »

    Je ne peux pas prouver que j’ai fait une MAJ. Comme je l’ai ecrit plus haut, je me suis contenté de copier dans le repertoire « web » de mon syno le dossier phpmyadmin avec la version 5.5 de mysql.
    Je n’ai fait aucune installation.

    Lorsque je me place à l’adresse http ://192.168.0.14/phpMyAdmin une fenêtre me demande un nom d’utilisateur « root » je suppose et un mot de passe que je n’ai pas renseigné mais cela ne m’oriente pas vers la page d’acceuil, l’accès y est refusé.

    Je continue a patauger mais je ne desepère plus autant que ce matin.

    #807

    lecardiologue
    Participant

    Bonne nouvelle, Roland est parvenu a me réécrire ma base DrTuxTest, l’importation sous XP pro n’a pas posé problème.
    Mon serveur NAS est devenu opérationnel pour Medintux.

    Finalement ce n’était pas un problème de version MYSQL sur le NAS.

    Je posterai avec la permission des modérateurs un papier sur le Wiki pour décrire les principales étapes de configuration.

    Quel soulagement ! 😀

    #808

    dajon
    Participant

    Félicitations à Toi et à Roland pour ce long travail et tant de patience et persévérance. Oh oui !! publies nous cela rapidementsur wiki sinon un post dans ce forum car cette option NAS est très intéressante.

    #809

    lecardiologue
    Participant

    OK c’est promis ! mais tout d’abord un grand merci aux compétences de Roland, Victor, Dajon et tous les autres que j’oublie certainement !

    #815

    lecardiologue
    Participant

    Au fait comment on fait pour publier sur le Wiki ?
    Faut-il créer un compte ?

    A plus

    #817

    dajon
    Participant

    Je crois qu’il suffit que tu clic sur wiki et que tu ailles dans la page qui t’intéresse puis faire modifier pour ajouter qq chose. Tu peux également créer une nouvelle page. Ton mot de passe au forum doit suffire semble t il mais je n’ai pas été jusqu’à essayer d’introduire une modif

    #818

    dajon
    Participant

    Oui c’est cela. Je viens de tenter par ex d’ajouter la plateforme NAS synogy à la page installation. Je n’ai pas enregistrer. Je te laisse faire !!!

    #819

    lecardiologue
    Participant

    Ok merci dajon !

    Malheureusement j’ai très peu de temps ce soir…je m’y collerai mercredi ou ce Week-end mais c’est promis.
    A propos j’ai un serieux problème pour mettre en ligne des photos de capture d’ecran pour les étapes de configuration, alors je vais essayer de trouver.

    A la prochaine !

15 sujets de 61 à 75 (sur un total de 79)

Vous devez être connecté pour répondre à ce sujet.