Se connecter à un serveur NAS Synology DS108J

Accueil FORUM Installation Se connecter à un serveur NAS Synology DS108J

Ce sujet a 78 réponses, 4 participants et a été mis à jour par  lecardiologue, il y a 7 ans et 11 mois.

15 sujets de 46 à 60 (sur un total de 79)
  • Auteur
    Messages
  • #735

    dajon
    Participant

    Tiens nous au courant. Merci.

    #737

    lecardiologue
    Participant

    Petite synthèse des derniers jours :

    1/ Le but du jeu était de RESTAURER sur mon SYNO DS108J mes bases Medintux (comprenant une centaine de patients à la date d’aujourd’hui) à partir de Sauvegardes réalisées au cabinet avec MySQL Administrator.
    Problème : cette sauvegarde en un seul fichier fait : 50 Mo environ
    PHPMYADMIN est installé en version non mise à jour sur le SINO (c’est quand meme surprenant quand on sait l’usage que l’on peut faire de ces NAS)
    Cette MAJ ne peut être faite de manière simple (c’est à dire pour un novice comme moi)

    2/ Methodes utilisées pour restaurer jusqu’a maintenant :
    a) avec phpMyAdmin : echec total que ce soit avec le fichier de sauvegarde initial 50Mo ou avec des fichiers scindant les bases de Medintux séparées.
    b) avec MysqL administrateur : echec total des deux manières.
    c) avec le bouton « Restaurer un fichier SQL » de Set_Bases : echec total également : des messages d’erreur sont affichés en langage MYSQL.

    3/ A chaque tentative de restauration j’ai pris soin d’effacer au préalable toutes les bases préalablement crées (sans enregistrement)par Set_Bases.

    4/ Pour finir j’ai trouvé sur le site web de synology une page qui soit disant permettrait de mettre à jour phpMyAdmin. Testé mais ça marche pas. Tout ça n’est pas très clair quand même…

    Pourtant il faut que je trouve une solution car je sens qu’elle est pas très loin…
    J’aimeari surtout eviter d’infliger à ma secretaire la recréation de 100 dossiers patient…cad de recommencer tout depuis le début.

    Avez vous d’autres idées…?

    #738

    lecardiologue
    Participant

    J’ai fait un autre essai :

    Après avoir installé WAMP sur mon PC (configuration MONOPOSTE), j’ai voulu savoir ce que donnerai une restauration sur ce dernier.

    J’ai verifié la version du client MYSQL dans WAMP, c’est la 5.5.16 donc superieure à celle qui est installé sur mon SYNO.

    J’ai restauré en utilisant le boutant du Set_Bases mais cela abotit à un echec, des erreurs de type INSERT TO étant mentionnées.

    Je n’ai pas essayé la même manip avec MySQL Administrator mais il est fort àparier que ça n’aboutisse pas non plus.

    Bref je suis de plus en plus convaincu que certaines de mes bases sont endomagées.

    A ce sujet connaissez vous un outil qui me les reparerait automatiquement ?

    Autre question : avec quelles bases minimales Medintux peut-il fonctionner et sur laquelle sont stockées les enregistrements que j’ai fait, vous savez les 100 patients ?

    Merci de votre aide et bon dimanche

    #739

    dajon
    Participant

    peut être essayer cette commande dans mysqladmin : mysqlcheck –auto-repair -u “user” -p “Nom de votre Database” ou databse est drtux je suppose

    #740

    dajon
    Participant

    sinon je crois mais je suis pas sur place en ce moment, que l’on peut réparer une base avec PhpMyAdmin

    #741

    dajon
    Participant
    #742

    lecardiologue
    Participant

    « essaies cela : http://www.tutoriels-astuces.com/phpmysql/comment-reparer-une-table-mysql-avec-phpmyadmin-message-is-marked-as-crashed-and-should-be-repaired/ »

    Merci Dajon !

    Ca avance cette fois !
    Les bases se réparent sous phpMyAdmin.
    Après réinstallation en local, j’ai pu lancer Medintux et acceder à mes cent patients.

    Je suis en train de procéder à la même manip sur mon SYNO : j’ai exporté mes bases réparées vers le SYNO.
    Je vous tiens au courant mais je sens que la solution est à portée de mains !

    😀

    #744

    lecardiologue
    Participant

    En fait je pense que je m’y prenais mal au niveau du SYNO.
    J’ai repris les choses en main : j’ai installé en premier les bases avec setbases.
    Ensuite je me suis replacé sur les bases installées en monoposte et ai exporté toutes les données enregistrées (et pas les bases).
    Je ne vais donc restaurer que les données sur mon SYNO.
    Je pense que cette fois ci ca va marcher…je croise les doigts++++

    #747

    lecardiologue
    Participant

    La restauration des données n’a pas marché non plus.
    Je me suis proposé un nouveau schéma : restaurer mes bases en monoposte, ça marche très bien car je retrouve tous les patients que j’avais crée au cabinet.
    Ensuite j’ai fait une sauvegarde en un seul fichier .sql que j’ai fabriqué avec mysql administrator.
    J’ai fait une restauration sur mon syno avec mysql administrator : le processus aboutit, les bases sont trouvées sur le setbases au nombre de 7 mais j’ai un message d’erreur, le suivant :

    Bases de données trouvées : 7
    . ‘DrTuxTest’
    . ‘MedicaTuxTest’
    . ‘BaseGetTest’
    . ‘CIM10Test’
    . ‘CCAMTest’
    . ‘QLaboFTP’
    . ‘Comptabilite’

    (==> Succès lors du test de l’accès à la base : test)
    ============ Erreur : GetMAJVersion()==============
    Erreur Get Version() initialisaton de la base non possible, installation des bases non correcte
    Echec de la connexion à Driver : QMYSQL3 base : DrTuxTest avec root@192.168.0.14:3306

    Que dois-je comprendre ?
    Quelle solution s’il y en a une ?

    Je crois ne pas être bien loin de la solution.

    #750

    dajon
    Participant

    c’est l’enfer ton truc !!

    #751

    dajon
    Participant

    ca ressemble vraiment au pb que j’avais eu en installant une nouvelle version de medintux sur une installation MAMP (sur mac) préexistante. Comme je te l’avais dit plus haut, je ne pouvais pas me connecter à mysql qui pourtant était ouvert (server sql open) car la version sql n’était pas compatible avec la version medintux. As tu la possibilité d’installer sur un autre pc la même sql que celle que tu as sur la NAS et voir si medintux peut ou non se connecter dessus ?

    #752

    dajon
    Participant

    sur un autre pc la même sql que celle que tu as sur la NAS et voir si medintux peut ou non se connecter dessus ?

    je veux dire en monoposte

    #757
    roland
    roland
    Admin bbPress

    Bases de données trouvées : 7
    . ‘DrTuxTest’
    . ‘MedicaTuxTest’
    . ‘BaseGetTest’
    . ‘CIM10Test’
    . ‘CCAMTest’
    . ‘QLaboFTP’
    . ‘Comptabilite’

    Je crois ne pas être bien loin de la solution.

    En effet c’est bon signe, le NAS est accessible et MySQL fonctionne.
    Il semble que les bases on été effectivement créées. Mais je soupçonne un PB de Majuscules Minuscules dans le nom des tables.

    1) Les bases initiales on été créées et alimentées sur quel environnement ?
    Windows, Linux Ou Mac

    2) Si c’est sous Windows, cela ressemble à un problème de nommage des tables avec mauvaise restauration des Majuscules Minuscules lors de la restauration sur un poste Linux (cas du NAS)

    3) Si c’est le cas :
    a- restaurer les bases sur un Linux quelconque.
    b- renommer les tables avec les bons noms en respectant les Minuscules Majuscules
    c- recréer le fichier sql avec Linux pour disposer des bons noms.
    d- remonter le tout sur le NAS.

    4) Si vraiment toujours pas de résultat, je suis prêt si vous êtes Ok à vous dépanner pour
    3) abc et vous renvoyer le sql à la condition que vous m’envoyez vos bases.

    Courage vous y êtes presque.

    #759

    lecardiologue
    Participant

    « 1) Les bases initiales on été créées et alimentées sur quel environnement ?
    Windows, Linux Ou Mac »

    Sous Windows XP

    « 2) Si c’est sous Windows, cela ressemble à un problème de nommage des tables avec mauvaise restauration des Majuscules Minuscules lors de la restauration sur un poste Linux (cas du NAS) »

    Aie Aie

    J’ai installé a la maison un PC avec dual boot : Ubuntu/Windows 7
    Je vais essayer d’installer les bases ainsi

    Concernant l’aide proposée, je vous fais signe des que je suis prêt, en tous cas merci beaucoup !

    #764

    lecardiologue
    Participant

    Pour Roland : désolé ma réponse fut trop courte ce matin 😳

    Si j’ai bien compris, des dumps de base réalisés sous Win$$XP ne peuvent pas être restaurées sous LINUX en raison de la mauvaise gestion de l’orthographe de Windows.
    Les deux systèmes ne peuvent pas communiquer entre eux, quel racisme !.
    Ce matin j’ai pu restaurer en monoposte Windows toutes les sauvegardes que j’avais réalisées initialement sous Windows, LOGIQUE.
    Ce matin j’ai voulu faire le malin en tentant une restauration complète sur mon syno à partir d’une sauvegarde unique .sql que j’avais fait sous mysql administrator.
    A la fin du processus, j’ai constaté l’existence des 7 bases de Medintux dans le Set-Bases, activées mais imossibilité de lancer Medintux faute de bouton « Démarrer Medintux » à côté du bouton « Quitter ».
    A mon humble avis cela signifie que les bases ne sont pas vraiment installées.

    Mon PC à la maison possède un dual boot Win/Ubuntu.
    Je vais essayer de procéder comme tu me l’expliquais dans ta dernière réponse.
    Victor et toi aller surement m’aider à conclure, je vous en remercie beaucoup.
    J’ambitionne en effet de faire marcher medintux en reseau au cabinet avec mon serveur NAS comme tour de contrôle (ce sera certainement plus élégant que d’avoir un PC en serveur).

    Je vous tient au courant de la suite.

15 sujets de 46 à 60 (sur un total de 79)

Vous devez être connecté pour répondre à ce sujet.