Impossibibilité installer libqt3 sous ubuntu 12.10

Accueil FORUM Installation Impossibibilité installer libqt3 sous ubuntu 12.10

Ce sujet a 5 réponses, 4 participants et a été mis à jour par  emile, il y a 8 ans et 6 mois.

6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #1856

    pigeon
    Participant

    Bonjour à tous,

    J’avais fait le choix de l’installation d’ubuntu 12.10 après moultes reflexions

    windows ou pas?

    fedora ,mandriva, mageia, debian,?

    ubuntu me paraissait au top.

    J’avais suivi le tuto video de victor avec la 12.04 mais  j’ai pris la dernière version d’ ubuntu la 12.10.

    Seulement pas de bol après installation de mysql , phpmyadmin p7zip sans probleme pour installer liqt3 ça coince sévère:

     

    root@ericpigeon-Vostro-1700:/home/ericpigeon# apt-get install libqt3-mt
    Lecture des listes de paquets… Fait
    Construction de l’arbre des dépendances
    Lecture des informations d’état… Fait
    E: Impossible de trouver le paquet libqt3-mt
    root@ericpigeon-Vostro-1700:/home/ericpigeon#

    je fouine sur le net et je trouve sur cette page quelque chose de tres inquiétant
     

    http://www.ubuntuupdates.org/package/core/quantal/main/base/libqt3-mt

    « la derniere repository d’ ubuntu est incompatible avec QT3 »

    Interresting no.

    Je suis dépité je vais donc rester avec medintux sous windows 7 c’est un comble

    Amitiés à tous et grand merci à Victor pour ses tutos vidéos.

    Eric PIGEON

    Ancenis

    #1857

    pigeon
    Participant

    Salut,

    J’ai télécharge libQT3 à cette adresse

    http://packages.ubuntu.com/fr/hardy/i386/libqt3-mt/download

    J’avance

    Je vous tiens au courant.

    eric

    #1858

    pigeon
    Participant

    Malheureusement

    les drivers mysql ne sont pas installés impossible de de se connecter à la base de données

    décidément l’installation de medintux est trop compliqué pour moi.

    Je jettes l’éponge.

    #1860

    gerard
    Admin bbPress

    Je me suis laissé dire que la libmotif installait qt3 sur la dernière ubuntu.

    Sinon, il faut downgrader ubuntu, ou installer mageia (totalement compatible) ou recompiler libqt3 à la main avec le support mysql.

    Ne lâche pas et tiens-nous au courant.

    #1867

    Victor
    Admin bbPress

    mince, en effet le support de qt3 a été lâché dans la dernière ubuntu.

    pour une architecture 32 bits (i386) :

    1. libqt3-mt : https://launchpad.net/ubuntu/quantal/i386/libqt3-mt/3:3.3.8-b-8ubuntu3
    2. libqt3-mt-mysql :  https://launchpad.net/ubuntu/quantal/i386/libqt3-mt-mysql/3:3.3.8-b-8ubuntu3

    pour une architecture 64 bits (amd64) :

    1. libqt3-mt ici : https://launchpad.net/ubuntu/quantal/amd64/libqt3-mt/3:3.3.8-b-8ubuntu3
    2. libqt3-mt-mysql : https://launchpad.net/ubuntu/precise/amd64/libqt3-mt-mysql/3:3.3.8-b-8ubuntu3

    selon ton architecture, télécharge les .deb correspondant, ça devrait faire l’affaire !

    #3072

    emile
    Participant

    Bonjour.

    Je travaille à installer medintux sur une machine de test debian jessie (nouvelle version stable) . Bien sûr j’ai le même problème avec libqt3-mt qui a bel et bien disparu des repositories de debian. Aucun package  debian n’ assure la comptabilité qt3-qt4. Il existe par contre un outil pour migrer les codes sources de qt3 vers qt4 dans le package libqt4-qt3support…

    Plus prosaïquement mes recherches acharnées sur google m’ont fait découvrir un site qui propose des dépôts contenant les fameuses bibliothèques qt3 : http://debian.tryphon.eu/ Pour les fans de ubuntu (pourquoi pas debian ?) il existe aussi des repositories.

    Vous n’avez plus qu’à modifier votre /etc/apt/sources.list, importer la clé publique : (become root !)

    wget -q -O – http://debian.tryphon.eu/release.asc | sudo apt-key add –

    mettre à jour

    apt-get update && apt-get upgrade

    rechercher tous les paquets qui vont bien :

    apt-cache search qt3

    les installer :

    apt-get install libqt3-mt-mysql libqt3-mt libqt3-i18n qt3-designer qt3-assistant qt3-qtconfig

    Et Tadaaaa ! Ça marche !

    J’implore les programmeurs de passer tout le code en qt4 sou speine de mort annoncée du projet ? Il m’est impossible d’ aider à le faire je n’ arrive à programmer. Un version supérieure à 2.14 pour linux me ferait plaisir.

    Un grand bravo à ceux qui maintiennent le projet et à ceux qui ont compris l’intérêt de cet outil génial.

    Bonne soirée à tous.

     

     

     

6 sujets de 1 à 6 (sur un total de 6)

Vous devez être connecté pour répondre à ce sujet.